Operating Systems

These are the minimum sytstem requirments to run The Learning Center:
 
  • Internet Explorer 9.x or later on Vista/ Windows XP
  • Firefox 30.x or later on Vista/Windows XP/ Linux
  • Safari 6.x or later on Vista/Windows XP/ OS X / iOS
  • Chrome on Windows XP/ Vista/ OS X/ Linux / Android

BACK TO SUPPORT / BACK TO MY COURSES