Browser

To ensure all the best possible experience for all NBOME Learning Center users, we recommend you use:

  • Google Chrome (PC and Mac) LINK
  • Firefox 30.x or later (PC and Mac) LINK
  • Safari 6.x or later (Mac) LINK
  • Internet Explorer 10 or 11 (PC) LINK

Users with older versions of Internet Explorer users may experience difficulties. If you do not already have one of the recommended browsers installed on your computer, simply click the LINK to be taken to the free download page. If you are using Internet Explorer 10 or 11, you need to disable Compatibility Mode. Click the LINK to learn how.

BACK TO SUPPORT / BACK TO MY COURSES